Tor Browser 7.5a10 is released

Tor Browser 7.5a10 is now available from the Tor Browser Project page and also from our distribution directory.

This release updates Tor to 0.3.2.7-rc and OpenSSL to 1.0.2n. The security slider has been updated, following the experience provided for mobile users. On Linux, the "Print to File" feature should be working again.

The full changelog since Tor Browser 7.5a9 is:

  • All Platforms
    • Update Tor to 0.3.2.7-rc
    • Update OpenSSL to 1.0.2n
    • Update Torbutton to 1.9.8.4
      • Bug 21847: Update copy for security slider
      • Bug 10573: Replace deprecated nsILocalFile with nsIFile (code clean-up)
      • Translations update
    • Update Tor Launcher to 0.2.14.2
      • Bug 24623: Revise "country that censors Tor" text
      • Bug 24428: Bootstrap error message sometimes lost
      • Bug 24624: tbb-logo.svg may cause network access
      • Bug 10573: Replace deprecated nsILocalFile with nsIFile (code clean-up)
      • Translations update
    • Update NoScript to 5.1.8.3
    • Bug 23104: CSS line-height reveals the platform Tor Browser is running on
    • Bug 24398: Plugin-container process exhausts memory
  • OS X
    • Bug 24566: Avoid white flashes when opening dialogs in Tor Browser
  • Linux
    • Bug 23970: Make "Print to File" work with sandboxing enabled
    • Bug 23016: "Print to File" is broken on some non-english Linux systems
  • Android
Seth Schoen

December 20, 2017

Permalink

14:25:29.848 Error: Callback received for bad URI: [xpconnect wrapped nsIURI] 1 permissions.js:231:11
onIndexedDBUsageCallback chrome://browser/content/pageinfo/permissions.js:231:11

Seth Schoen

December 20, 2017

Permalink

Update Failed
The partial Update could not be applied. Tor Browser will try again by downloading a complete Update.

Is this normal???

Seth Schoen

December 20, 2017

Permalink

'The Rise of ``Worse is Better''' by Richard Gabriel. (25 years ago)
https://en.wikipedia.org/wiki/Worse_is_better
Il meglio è nemico del bene is a less absurd/idiot version.
https://en.wikipedia.org/wiki/Perfect_is_the_enemy_of_good (400 years ago)

1° mit is not a reference.
2° an obsolete way of life showed like a model of style/design is a demonstration of an inapt mind.
3° Better crypto (replaced SHA1/DH/RSA1024 with SHA3/ed25519/curve25519)
https://trac.torproject.org/projects/tor/wiki/doc/NextGenOnions#Howtoco…

It does not solve our tor user problem , wait 5_10 years before running a modern tor version is not a good *enough attitude.

Does an onion grow up on the same ground than a rose ?
https://blog.torproject.org/tor-browser-75a9-released

Seth Schoen

December 20, 2017

Permalink

Tor NOTICE: Switching to guard context "default" (was using "bridges")
Tor WARN: Could not choose valid address for OzDqSJWvi2NFpDubvxp
Tor WARN: Failed to find node for hop #1 of our path. Discarding this circuit.
Tor WARN: Could not choose valid address for OzDqSJWvi2NFpDubvxp
Tor WARN: Failed to find node for hop #1 of our path. Discarding this circuit.
... indefinite number of times ...
switching from obfs4 to `firewalled` guard option fucked up as expected :-)

Seth Schoen

December 22, 2017

Permalink

Last night my Tor connection broke. The Tor Arm console had an error message saying something like my "Guard node has already failed more than 700 circuits, possibly doing some routing attack". I didn't save the Guard node ID.

Seth Schoen

December 24, 2017

Permalink

Audio, that I needed for things like message notification, does not work at all, no sound at all, ever since the switch to pulseaudio. I have pulseaudio installed and working, that isn't the problem.

Seth Schoen

December 24, 2017

Permalink

16:40:51.869 uri is undefined 1 MatchPattern.jsm:95
matches resource://gre/modules/MatchPattern.jsm:95:1
matches/< resource://gre/modules/MatchPattern.jsm:118:42
some self-hosted:208:1
matches resource://gre/modules/MatchPattern.jsm:118:12
urlMatches resource://gre/modules/WebRequestCommon.jsm:55:12
shouldRunListener resource://gre/modules/WebRequest.jsm:549:12
runChannelListener resource://gre/modules/WebRequest.jsm:692:14
errorCheck resource://gre/modules/WebRequest.jsm:568:7
runChannelListener resource://gre/modules/WebRequest.jsm:676:20
onStopRequest resource://gre/modules/WebRequest.jsm:841:5
onStopRequest resource://gre/modules/WebRequest.jsm:351:5

Seth Schoen

December 30, 2017

Permalink

New install of 7.5a10 on Windows 7. Out of the box settings fail Panopticlick fingerprint test. Unique fingerprint. Moving security settings up to medium same result. Turning off almost all settings in NoScript make test non-functional so unsure if still unique fingerprint.

No HTTPS Everywhere. Shows as enabled in Menu > Addons but no button visible on browser as in earlier versions.

Seth Schoen

January 07, 2018

Permalink

need to download 5.7 foe osx 10.6 cant update computer to new system so must have tor 5.0 or im sh%t out of luck can fid a link that dont send me to 7.1 or higher

I'm running macOS Sierra and I use both versions. I think that 7.5a10 is an alpha that runs some experimental features...(I'm guessing it's the same for Linux, although Linux still has a hardened version if I'm not mistaken. It's been awhile since I looked at the downloads available). and 7.0.11 is the latest stable release.

They differ in the sense that the version with the "a" in its version string (the alpha) usually contains patches that need to get tested in a wider audience across all the platforms we support. This can be new bug fixes to the browser part, a new toolchain or a new build environment etc. Thus, it is hard to write about specific changes between alpha and stable series. One of the changes between 7.5a10 and 7.0.11 is the Tor version shipped. The alpha release contains the latest Tor alpha version while the stable sticks to the latest stable Tor version.

Seth Schoen

January 18, 2018

Permalink

When you set a certain window size a warning pops up.
How do you prevent the browser from telling its window size ?

Seth Schoen

January 20, 2018

Permalink

When New TOR 7.12 and new Tail 3.5 arrives. Tail 3.4 has a lot of issues. We appreciate speed up the operations. Why Tail 3.4 is still TOR 7.10 and does not update to 7.11 so on. Please make Tail in a way at least TOR can be updated .

Join the discussion...

This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.

7 + 7 =
Solve this simple math problem and enter the result. E.g. for 1+3, enter 4.